Results 1 to 2 of 2
  1. #1
    Regular Member m00`'s Avatar
    Generation
    3rd Gen
    Model
    Si 4ws
    Join Date
    Aug 2012
    Location
    New South Wales
    Posts
    267

    Dash 'brake lamp' and parking light on

    1991 Honda Prelude
    When I start the car the brake lamp and parking/handbrake light on the dash are off however when I depress the brake pedal all the way in and let go, the brake lamp and parking light turn on on the dash. I have no idea whats causing this!

    Brake fluid is on MAX
    All brake lights work
    Brake pads seem fine
    Brakes feel no different than they ever have!

    Any ideas??
    "You don't feel the speed, in a way. You just don't feel the speed. The car is so stable and so comfortable.. unless you look at the speed gauge you don't realise you're going that fast. This is a good compromise between the sporting side and the comfort side. As I said, I think it is a super, super car." - Ayrton Senna

  2. #2
    Senior Member Sean628's Avatar
    Generation
    3rd Gen
    Model
    Si 4ws
    Join Date
    Mar 2011
    Location
    Victoria
    Posts
    945
    handbrake light could just be the connector next to the handle, cant remember what it looks like atm, but you need to take out the center console to check, I had same prob w the brake light, swap out the unit behind the lights housing and prob disappears, but if all brake lights working I woundnt worry about it

Similar Threads

  1. speedo, brake lamp, park lamp and s4 lamp, engine light
    By dimodavi in forum Third Generation
    Replies: 9
    Last Post: 8th April 2012, 12:11 AM
  2. parking brake lamp??
    By white_lude85 in forum I.C.E / Electronics / Security
    Replies: 3
    Last Post: 24th June 2007, 01:07 PM
  3. Brake Lamp Light
    By mattsama in forum Third Generation
    Replies: 4
    Last Post: 11th January 2007, 12:10 AM
  4. Brake Lamp - Light On
    By michaelmr2 in forum Fourth Generation
    Replies: 8
    Last Post: 26th June 2005, 05:58 PM
  5. ABS, Brake & Parking Brake Light Fault
    By tonee in forum Third Generation
    Replies: 0
    Last Post: 4th April 2004, 11:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •