Results 1 to 5 of 5
  1. #1
    Junior Member
    Generation
    3rd Gen
    Model
    2.0 Si
    Join Date
    Jun 2015
    Location
    New South Wales
    Posts
    3

    Cool New 3rd gen owner from Kensington NSW and join this big family!

    Hey guys, i recently bought a 1989 3rd gen prelude just for the pop up lights lol.

    i drove it down south from new castle to sydney.

    i got some pics for it and i took them at the IMO car wash sides the Syd Airport with my daily car accord.

    BbsImg143928990734145_562-676.jpg

    BbsImg143928999975311_721-492.jpg


    but these two days i got some problem, the clutch pedal stayed on the ground, gave no response to any action, and i cannot go into any gear.

    i took the car to the workshop and they changed the clutch master cylinder for me but the problem shown up again after i drove away from the workshop for about 20km.

    do you guys have some suggestions? I really don't wanna change the clutch cause the job will cost me a leg. (The workshop said they'll do it around 1200 dollars combine labor and material)

    Thanks a lot !!

    Really want to join your car meet some day with my back to work clutch lol.

  2. #2
    Junior Member
    Generation
    3rd Gen
    Join Date
    Oct 2014
    Location
    Queensland
    Posts
    61
    Check to see if the soft clutch hose is leaking, people commonly have to replace those.

  3. #3
    Junior Member Valentich's Avatar
    Generation
    3rd Gen
    Model
    Leater interior
    Join Date
    Sep 2014
    Location
    New South Wales
    Posts
    87
    Yep it probably a leak somewhere . When I got mine it did the same thing . I changed the master clutch cylinder and it was fine then .

  4. #4
    Senior Member yuvi's Avatar
    Generation
    Non Honda
    Model
    WRX
    Join Date
    Jun 2006
    Location
    New South Wales
    Posts
    635
    welcome! great car you have there.

    as for the clutch. seeing how you have a new master cylinder, check the clutch hoses etc..at best, you would be a new soft hose which an absolule easy fix.

    also check the slave cylinder, if the bleed nipple was not tightened properly it maybe leaking there.

    check and keep us posted.

    HRPM Motorsports - "Driver development is equally if not more important than building a fast car"

  5. #5
    Senior Member lorby's Avatar
    Generation
    3rd Gen
    Model
    Si 4ws
    Join Date
    Aug 2008
    Location
    New South Wales
    Posts
    882
    Welcome to PA! 3rd gen for life haha

    Sounds like the clutch system is still leaking, so as others have said gotta find the leak. I highly doubt it is the clutch/pressure plate otherwise it wouldn't have worked for 20kms. Check the hose in it's entirety for splits or cracks. Check where it joins the hardline (there's a bracket on the side of the engine bay). And then check the slave cylinder itself. If it's dropping pressure like that it should be fairly easy to find the leak as it will still be wet with brake fluid.

Similar Threads

  1. New 5th Gen Prelude owner from Penrith NSW
    By Noobish in forum Introductions
    Replies: 23
    Last Post: 4th August 2015, 09:39 AM
  2. new 3rd gen owner
    By hamm in forum Introductions
    Replies: 17
    Last Post: 26th November 2007, 06:34 PM
  3. 3rd gen big brake kit, now available..!!!!!!
    By ludemobile in forum Third Generation
    Replies: 18
    Last Post: 11th February 2007, 05:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •