Results 1 to 11 of 11

Thread: Austro's BA4

  1. #1
    Junior Member
    Generation
    3rd Gen
    Join Date
    Oct 2014
    Location
    Queensland
    Posts
    61

    Austro's BA4

    Hey guys, finally making an intro/build thread. I got this car way back in February and I signed up on PP and here straightaway, but something messed up with getting a registration link.... either way I'm here now, so all good.

    Long story short, caught the bus and train down to Nerang with two mates to pick it up for a grand, got home fine. Only issues were the battery was boned and it had practically no clutch fluid. I'm 20 this year but still on my Ls (bit of a story but I'm working on it), and I don't have anywhere to work on it at my place because my driveway is a 30 degree incline, as a result I've had to do all the work at a mate's place down the road. He moved out a month or two ago, so pretty much have to get my Ps asap.

    Finally got RWC and rego for it today. Bit of a scare since both this morning and the last time I tried to start it (I only do it occasionally) it would click when I turned to ignition but everything would die. No power in accessories either, and this is with a freshly charged battery. After a couple of minutes I gave it a go again and it cranked and turned over (just as the guy was leaving lol), judging from what people have said it seems like a starter/relay issue?


    i.imgur.com/s2CC7EH.jpg

    When I first got it. (How small do I have to make the photos for me to be able to embed them?)

    i.imgur.c_om/EaGOODG.jpg

    i.imgur.c_om/3peMyng.jpg

    As it sits now. Did all the basic stuff like leads, spark plugs, fluids and filters (except for MTF and oil filter since it seemed pretty new). Got a new radiator, RE002s, ran fat fives for a while then got those Impuls, hacked up teg intake, and a couple of other small things here and there. Got a pair of DBA T2s and Protex rotors ready to go on with some new pads, also have enough money saved up for BC V1s, a Momo and either headers/catback. Already know what I want to do with the car, just need the funds and time I guess haha. If I didn't stumble across it I would've probably built a high comp D15/16 Civic, so I think I'll stay NA with this and go boost when I eventually get a Civic or something FR.

    Quick question too: the torx bolt in the 4WS alignment tool slot has been stripped to all hell. I plan to replace it with an allen head bolt instead, but because it's in such an awkward place, would I be right in assuming that I'd have to remove the chassis bracing that runs underneath it to get to it? How much of a mess around would it be? I bought a tool from Nailbender on PP, so dealing with this is the only reason why I haven't ordered coils yet since I want to be able to get an alignment right after I throw them on.

    Cheers for reading, any comments and tips are appreciated.... I'm familiar with quite a few of the cars both on here and PP from lurking hard so feel free to say hi haha

  2. #2
    PA Janitor Bob's Avatar
    Generation
    3rd Gen
    Model
    Si 4WS - B Spec
    Join Date
    Jan 2006
    Location
    Western Australia
    Posts
    11,091
    Hi, welcome to PA and from the pics it looks like the externals are in good nick. Hope you can sort through the other issues.

    The starting issue could be the ignition switch.

  3. #3
    Junior Member
    Generation
    3rd Gen
    Join Date
    Oct 2014
    Location
    Queensland
    Posts
    61
    Hmm ok, I'll look into that. No insight into the torx bolt issue?

    There's a patch of rust bubbles that have broken at the bottom right corner of the windscreen on the quarter panel, that plus surface rust above the front windscreen where it's supposed to have trim and rubber are the two main external things I have to deal with. There are a couple of bubbles an inch or two below the fuel filler but they aren't too big so I'm gonna leave those.

  4. #4
    Regular Member Gregsir's Avatar
    Generation
    4th Gen
    Model
    Si-Vtec
    Join Date
    Dec 2011
    Location
    Queensland
    Posts
    225
    Hey welcome,your only a stone throw from me,i'm in Pacific Pines.
    Work on the image hosting,do a preview and see it if they come up or just attach them and link them.
    Resize them first or most host sites resize as an option before taking the image.
    Nice line up for the car,your off to a good start.
    Where the Dba's pricey?

  5. #5
    PA Resident Flipmods's Avatar
    Join Date
    Nov 2003
    Location
    New South Wales
    Posts
    3,513
    Welcome!!!
    Yes as Bob said check your ignition or maybe a bad earth to the engine/starter motor. Doesn't sound like the main relay as you still have reds and cranking if your relay was stuffed.

    BRING BACK THE FORUMS!

  6. #6
    Junior Member
    Generation
    3rd Gen
    Join Date
    Oct 2014
    Location
    Queensland
    Posts
    61
    Quote Originally Posted by Gregsir View Post
    Hey welcome,your only a stone throw from me,i'm in Pacific Pines.
    Work on the image hosting,do a preview and see it if they come up or just attach them and link them.
    Resize them first or most host sites resize as an option before taking the image.
    Nice line up for the car,your off to a good start.
    Where the Dba's pricey?
    Yeah I just kept getting an error related to the number of URLs in a post, which doesn't make any sense.... I'm not new to forums by any means so was kinda stumped. I did resize them to roughly 900x500.

    Was just going to get blanks but I got them for ~$120 each as SCA had them for 25% off. Their system also suggests that they do the 3000/4000 series (contradicting the DBA website) but those are like $400 each retail, screw that lol.

    Also, I'm actually from west Brisbane, just bought the lude from some wholesale dealer in Nerang. Interesting story behind it haha.

    Quote Originally Posted by Flipmods View Post
    Welcome!!!
    Yes as Bob said check your ignition or maybe a bad earth to the engine/starter motor. Doesn't sound like the main relay as you still have reds and cranking if your relay was stuffed.
    Ah ok, thanks for the insight. Has been starting fine every time I've driven it in the past few days so not going to worry about it too much for now, will check it out at a later date.


    Ordered a weighted Razo shift knob today because I got sick of the stock unit occasionally rotating slightly when I shift hard. Got more shifts than usual lined up over the next month too so should have mods aplenty once I get around to my Ps.
    Last edited by Austro; 4th October 2014 at 02:18 AM.

  7. #7
    Junior Member
    Generation
    3rd Gen
    Join Date
    Oct 2014
    Location
    Queensland
    Posts
    61
    Post denied. New posts are limited by number of URLs it may contain and checked if it doesn't contain forbidden words.
    Tried both imgur and photobucket, won't work?

    Click image for larger version. 

Name:	v7jDkyO.jpg 
Views:	12 
Size:	17.5 KB 
ID:	8508

    Only if I select local referencing :/
    Attached Thumbnails Attached Thumbnails 10721046_10204056262999881_1593040911_n_zps62b343c3.jpg  

  8. #8
    Junior Member
    Generation
    3rd Gen
    Join Date
    Oct 2014
    Location
    Queensland
    Posts
    61
    I gave up on updating this since the forums were relatively dead and I mainly post on PP, but here are some photos.









    And that's not everything that has happened since last year I've got my BB1 front calipers (doing rear rotors too and all the lines with Goodridge units) ready to go, just need to get the Mini Cooper rotors slotted. I tried running the Whiteline front and rear sway bars but the increase in understeer over the stock bars is phenomenal, so I'll be going back to stock front. My Honda Access side skirts are finally ready to go on, would have done it today but it was pissing down rain and ditto with repainting my hood and roof with code matched rattle cans. Cusco front and rear strut braces will be ordered with tax return money, and I think those are the main things off the top of my head. Overall plans are still the same, so I'll keep updating this occasionally as things come in. Those who are interested can just follow my PP build thread but even that doesn't get updated often, haha.

  9. #9
    PA Janitor Bob's Avatar
    Generation
    3rd Gen
    Model
    Si 4WS - B Spec
    Join Date
    Jan 2006
    Location
    Western Australia
    Posts
    11,091
    Beautiful selection on the seats. They really suit the car.

  10. #10
    Regular Member Gregsir's Avatar
    Generation
    4th Gen
    Model
    Si-Vtec
    Join Date
    Dec 2011
    Location
    Queensland
    Posts
    225
    Loving the interior

  11. #11
    Junior Member
    Generation
    3rd Gen
    Join Date
    Oct 2014
    Location
    Queensland
    Posts
    61
    Thanks guys! I have good plans for the interior but I feel like I should spend more money on the important things first.... my rust bubbles are getting bigger so they need tending to soon on a weekend. But I will definitely be getting some interior bits within the next month or so that will really set off the theme I have going. Even though I don't want most of the optional parts, my list of OEM bits that I want is still sizeable and seemingly hard to obtain rain visors, OEM S1 rear lip, map light, hood bra etc

Similar Threads

  1. BA4/BA5 Clutch
    By AYRTON in forum Third Generation
    Replies: 14
    Last Post: 30th July 2012, 03:55 AM
  2. Ba4?
    By mickydrip in forum Third Generation
    Replies: 2
    Last Post: 10th September 2011, 09:03 PM
  3. Jarik's '91 BA4 S2 Si 4WS
    By Jarik in forum 3rd gen
    Replies: 67
    Last Post: 28th April 2010, 12:17 AM
  4. BA4 Vs BA5
    By Bob in forum Third Generation
    Replies: 11
    Last Post: 28th July 2007, 02:30 PM
  5. Project : BA4 Camshafts
    By Papa in forum Third Generation
    Replies: 9
    Last Post: 26th July 2007, 12:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •