Results 1 to 7 of 7
  1. #1
    Junior Member
    Generation
    5th Gen
    Join Date
    Nov 2013
    Location
    New South Wales
    Posts
    4

    knock sensor issues

    Hi guys im new here so sorry if i could have put this in a better section ( like my own build thread but i couldn't find that section )

    i recently found a oil leak behind my intake manifold, searching for it with my hand i found a sensor, i thought i may have been leaking from there so i attempted to unplug the sensor and instead of the plug coming off the sensor i snapped the male part of the sensor off the sensor itself and it was still plugged into the harness ( lol idiot i know..) i slid the sensor back together ( still plugged into harness) and continued driving the car with no issues, a week later i decided i was going to rebuild my engine and did so, whilst the car was out i replaced the sensor with a new $30 ebay speacial Knock sensor.

    on first start up no issue but now it throws a code after 2 mins of driving i pulled the code and yep.. knock sensor is the issue so i unbolted it an put my old brocken one back in and no more issues..

    the odd thing is i checked both for continuity and ohms.. and both gave me no continuity and Open loop.

    so im a bit stumped the broken ones back in now and no check engine light, although i cant help wonder if the new one was ok and was giving correct readings that there actually is a issue in my engine.. or if the new one was incorrect part and was throwing codes or something else stupid does anyone have any experience with these things???

  2. #2
    PA Janitor Bob's Avatar
    Generation
    3rd Gen
    Model
    Si 4WS - B Spec
    Join Date
    Jan 2006
    Location
    Western Australia
    Posts
    11,091
    No experience with it but it may be possible that the sensor is somehow calibrated to the the ECU. By using an alternate sensor it may give a different output and hence fault code. Just a hunch.

  3. #3
    Junior Member
    Generation
    5th Gen
    Join Date
    Nov 2013
    Location
    New South Wales
    Posts
    4
    hmm cheers for the input bob, all i know is now the car is running fine... odd but im still a bit worried lol.

  4. #4
    J "The Stig" B 94vtirozguy's Avatar
    Generation
    4th Gen
    Model
    VTEC
    Join Date
    Sep 2005
    Location
    Victoria
    Posts
    2,980
    before replacing anything in your car you need to ensure it is compatible with stock specs. things like sensors have different tolerances and ways they are triggerred. This also must be sending the right values back to the ECU.. generally they send a voltage back based on a reading the sensor takes.. So if you are using a 5v sensor and its actually 12v you can guess there is information that is expected not recieved by the ECU.
    ------------------------------------
    Winton : 1:48.2
    Sandown : 1:38.3

  5. #5
    Silver Member renzokukenj's Avatar
    Generation
    5th Gen
    Model
    Si
    Join Date
    Jul 2009
    Location
    Western Australia
    Posts
    1,047
    I would replace the sensor with the appropriate sensor from Honda

    I think they are around $50?
    ʍǝɹɔ uʍop ǝpısdn

    私の進行中のスレッドを確認してください
    Quote Originally Posted by lommytam2342 View Post
    Hey Furo, whats the finger spacing for your rear?
    Quote Originally Posted by Son of Eevil View Post
    How much do I have to pay you or how much dick do I have to suck to get you to take me for a ride?!

  6. #6
    Junior Member
    Generation
    5th Gen
    Join Date
    Nov 2013
    Location
    New South Wales
    Posts
    4
    appropriate sensor from honda $200...

  7. #7
    Senior Member Sean628's Avatar
    Generation
    3rd Gen
    Model
    Si 4ws
    Join Date
    Mar 2011
    Location
    Victoria
    Posts
    945
    from the wrecker if you not gonna pay 200 for a new one

Similar Threads

  1. Knock sensor
    By Ollie in forum Fourth Generation
    Replies: 2
    Last Post: 27th September 2010, 08:22 PM
  2. Knock Sensor
    By DRK291 in forum Fourth Generation
    Replies: 25
    Last Post: 4th December 2007, 01:45 PM
  3. Got Cel for knock sensor
    By crazylee27 in forum Fifth Generation
    Replies: 1
    Last Post: 16th November 2004, 08:30 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •