PDA

View Full Version : [HELP] DIY 5th gen Suspension



theseven
18th September 2006, 10:48 PM
hi all,

does anyone has anything regarding diy installation for suspension kit... i know most of them but just to make sure where the bolts location and stuff... if possible with pics... anyone has website to recomend? like the diagram and stuff to take the stock ones off...

thanks all

grnLude
18th September 2006, 11:28 PM
http://www.ntpog.org/mods/fifth-springs/fifth-springs.shtml

This is a basic write up for installing a suspension setup in a 5th gen..

Menthu Rae
18th September 2006, 11:42 PM
Thanks for covering me grnLude, haha was looking for that but didn't have time... so busy right now ^_^

theseven
19th September 2006, 12:34 AM
thanks mate... it's great... with pictures as well.. perfect!! :biggrin: :love:

theseven
19th September 2006, 09:29 PM
got something else other than that?? just in case... hehe... i'm doing it on friday... anyone wanna help... hehehe

grnLude
19th September 2006, 09:32 PM
The fronts are easy..

The back is a bitch. When I did mine I spent about 3/4 of the time trying to the back..

theseven
19th September 2006, 09:45 PM
is it the back rubber bit that u have to use somekind of fork lift thing to take off??

how long did u spend to get the job done mate?!? i got 2 other friends to help me out... with all the tools...

any suggestion whether doing it fronts or rears first... was planning on starting on 3 till like 9... so 6 hours... enough?!? can just continue the next day if not finished though...

grnLude
19th September 2006, 09:54 PM
The fronts are easy, shouldn't take more than 2 hrs to do the front.

For the back you need a pitmans arm puller or a pully remover can be used as well if you are carefull.

I did mine without removing that bit. It will be a bit easier if you do remove it.

theseven
19th September 2006, 09:58 PM
rright o... so that bit isn't actually the bolts that hold the shock?? can be done without taking it out?? ow k... cos i still don't have that kind of puley for that so want to figure out whether will need them or not...

i got mine bone stock and i'm not sure wheter he changed the suspensions before yet or not... if he did it might also be easier since all the bolts aren't gonna be that hard to pull out...

theseven
20th September 2006, 07:26 PM
i'm changing the shock as well... i heard that the shock need some bits from the stock shock to be able to installed?? what is that bit that i need to take out from my stock?

thanks

grnLude
20th September 2006, 08:25 PM
The top mounts...

You need a spring compressor to remove the stock top mounts..

theseven
20th September 2006, 10:50 PM
u mean the 'mounts' are kinda brackats that hold the suspensions to the car??

thanks heaps for ur help... really helpful!! i'll let u know when it is done :biggrin:

- friday another 2 more days riding a high lude :D -

Mitchman
21st September 2006, 02:35 PM
lol i did all 4 with my socket set n just my 2 arms lol and no instructions lol not braggin, it was a ****in good learning curve but yeah the fronts took me bout 2 hours n there rears would have taken 3 if one of the bolts undid when i told it to!!! 4 hours in the end lol now i have green teins :-) good fun! got myselft real filthy lol good luck!

theseven
21st September 2006, 05:27 PM
about the mounts bits... is it on the front only or both??

grnLude
21st September 2006, 05:33 PM
^both...

I'll be home most of Friday.. If you get stuck just post on here and I'll help you out..

theseven
21st September 2006, 09:07 PM
ah great... thanks man... at least i got a back up... hehehe... will start on 12 o'clock tomorrow my time (Adelaide) hehe... will let u know if got problems or it's done.. hehe

Hooman
22nd September 2006, 01:25 AM
Good luck with the install...hopefully all goes well and u don't damage yourself or your car.....watch out for those springs......make sure they r clamped tight......

theseven
22nd September 2006, 03:32 PM
hhelppp... cannt take the suspension out of the bracket... the front ones it is... took all the screws out... but when it comes down... some steel brackets holds it up...

grnLude
22nd September 2006, 04:11 PM
http://i2.photobucket.com/albums/y23/grnlude/Sus.jpg

You have to remove the bottom bolt on the "damper fork" to be able to take the shock out...

theseven
22nd September 2006, 11:48 PM
yea i did... that took like 1 hour to figure out... dammnnn... didn't say in the instruction... got both of the front ones in... and still got right rear to be done... replace the left rear... only need to tightened up things to get it on hold... uhhh... have to continue again tomorrow morning to finish up... know what should do already so should be easy... heheh

called hooman lots of times... hehe he's very helpful although sometimes doesn't know what i'm talking about.... hehehe

btw just checking... i didn't use any spacer... no spacer at all on the suspension... so what it holds only the rubber and the steel stock top mounts... and 2 rubbers there... should it be fine or i wull need some spacer?!? installed all the fronts without spacer...

grnLude
22nd September 2006, 11:51 PM
^nice...

I struggled with the left rear one when i did mine...

post a few pics when you are done.

theseven
22nd September 2006, 11:52 PM
Good luck with the install...hopefully all goes well and u don't damage yourself or your car.....watch out for those springs......make sure they r clamped tight......

lol... the spring jump once!!! the first time... after took it out of the stock shock... try to loosen it up and it jumped... maaannnn lucky didn't hit anything besides the ground... fiuuuhhh :sick:

theseven
22nd September 2006, 11:55 PM
^nice...

I struggled with the left rear one when i did mine...

post a few pics when you are done.


hooman, did u do without any spacer???

grnlude is that fine without any spacer on??!?? none i mean nothing!!! cos the koni's steel was too big compared to te stock ones...

need suggestion now... i'm gonna put at least 18 on that car maybe by the next 2 weeks... hooman did his rear on the middle bar... cos the lowest bar he said it rubs the guard... but i want to put it as low as to the grouundd?!?!? would it possible?!?!

grnLude
23rd September 2006, 12:21 AM
I'm not sure about the koni's, I would keep it in the middle bar for now.. You can adjust it later if you need.

What are the spacers? where do they go?

I have adjustable sleeves so I can change my height when ever I want..

Hooman
23rd September 2006, 12:23 AM
spacers????? i didn't use any!!!!!!
on 18" wheels with the offest i had with my rims i rubbed on the rear, but if u get 18's with the right prelude offset u can go as low as you want....may be a good idea to roll the rears guards......

theseven
23rd September 2006, 12:33 AM
@hooman
hhehe... what was ur offset wheels and how wide it was hoo?? thanks alot for ur help man... really appriciate it... even though sometimes we didn't click each other... but i called u like 7 timess today??!!?? lol.. :love:

uumm... yea to adjust it do i need to take the whole suspension out?!?

no not spacers... i mean washers... lol... wrong typing...

@grn
thanks man.. ur also very helpful for the last couple of days... since ur the one that told me the website for step by step... thx alot...

thx all of u for ur patients guiding this newbie... hehe

almost come to and end now... heheh.. i'll post the picture here as soon as it is done... maybe by lunch tomorrow :D

theseven
23rd September 2006, 02:52 PM
gguyyss it's done... very happy with the fronts... but the rear... need to get abit lower.... uuuh... hoo, was it hard to change the clips to be lowered? do i have to take the whole suspension out to do that?!?

i'll post some pics later... since i don't have any camera... huhuh... i'm a poor guy... so i'll wait for my friend to take the pict for me...

theseven
23rd September 2006, 02:55 PM
o yea also... ur setup was the front ilegal and rear legal right?!?

theseven
23rd September 2006, 05:54 PM
here u go... uuhh someone bump into me in the u park china town :(

http://i9.photobucket.com/albums/a51/beckham_totti/IMAGE_00005.jpg

http://i9.photobucket.com/albums/a51/beckham_totti/IMAGE_00006.jpg

grnLude
23rd September 2006, 06:01 PM
Looks good...

Need to lower the back a bit and it should look sweet..

theseven
23rd September 2006, 06:03 PM
Looks good...

Need to lower the back a bit and it should look sweet..

yea that's what i'm talking about before... need to change the pins on the back to get it lower than that... u think should change it?!?

http://i9.photobucket.com/albums/a51/beckham_totti/IMAGE_00008.jpg

grnLude
23rd September 2006, 06:05 PM
Yeah, lower the back.. It doesn't look level at the moment..

theseven
23rd September 2006, 06:12 PM
yea man... the more i see the pict the more i want it to get it done... geeee i'll try doing it tomorrow...

Hooman.... can u lower the suspension without taking them out?? is it possible to clamp the spring when they all in the car?!?

theseven
23rd September 2006, 09:22 PM
it's done guys... it's lowered AGAIN... to the ground... :biggrin: :love:

theseven
23rd September 2006, 09:29 PM
grn, have u got the ones on the back... the diagram like that front ones... i need to buy something out of it..

cheers

Hooman
24th September 2006, 12:03 AM
yea man... the more i see the pict the more i want it to get it done... geeee i'll try doing it tomorrow...

Hooman.... can u lower the suspension without taking them out?? is it possible to clamp the spring when they all in the car?!?

Yes, u clamp the springs and open the clip and lower the spring perch....there is no need to take out the suspension when lowering or raising.....Hope you enjoy the suspension as much as i did........and keep away from those COPS!!!!!!

theseven
24th September 2006, 04:30 AM
Yes, u clamp the springs and open the clip and lower the spring perch....there is no need to take out the suspension when lowering or raising.....Hope you enjoy the suspension as much as i did........and keep away from those COPS!!!!!!


lol... cann't get it done that way... don't know why but the spring is not clamped enough... so i took out the suspension again before...

what kind of spring clamps u have? mine is bit biger so it's hard to clamp the spring when the suspensions are on the car... and also strugling to change the clip over when they were on the car... how did u do it?!? :umm:

also when they were installed in urs, were there alot of sounds when the suspensions is moving?? heard alot of sound coming out of all the suspension when going on a rough road...

hehe will stay away from the cops... hehe

Hooman
24th September 2006, 07:19 PM
When i had them installed they were very quite....i bit bumpy due to the lowering, but sound wise they were fine.....sure you got them installed properly????? Take it to an suspension place and get them to check it.....

grnLude
24th September 2006, 09:16 PM
there will be a few sounds till the suspension settles...

Get a wheel alignment done asap..

theseven
25th September 2006, 04:27 AM
@hooman
will they charge for inspecting them?? hehe... i'm doing DIY cos i don't want to give money easily to services people... if i don't have to... that's why i bought all the tools instead... so i can do anything else rather than spending 250 on 1 installation...

@gnr
yea maybe it needs sometimes to settle on the car... thinking of getting rims in next 2 weeks or so... so i'll get it done at the same time...

theseven
1st October 2006, 05:32 PM
BAADD NEWWSS...!! the suspension almost went through to the bonnet this morning!!! it was off... the rubber didn't hold them on so the actual shock is raising to the bonnet... it's because i didn't use any washers!!!

@hooman...
are u sure the washers didn't come with the suspension?? one of my friend got koni for lancer and they all comes with it... u sure it's still not on ur car... all the washers that u gave me was the stock ones... didn't fit koni yellow!!

i got some washers of bunnings but the size didn't match perfectly!!

Menthu Rae
1st October 2006, 05:50 PM
This is why you never fk around with suspension unless you know what you're doing.

Be careful man, you shouldn't have driven it if you weren't sure about it - and if it was making audible noises - you should have stopped driving and had it checked out ASAP.

Good luck getting it fixed up and hope you didnt damage your car or suspension.

theseven
1st October 2006, 05:59 PM
i put some washers on and it fixed.... but i bought the washers off bunnings so it didn't fit perfectly... should hold it for now but i need to get the right perfect size to make sure...

anyone knows where i can get them?!? the perfectly fitted cylinder size?!?

cheers

this is the washer that i'm missing..!!!
http://www.we-todd-did-racing.com/wetoddimage.wtdr/wNDI4NTI5NnM0MTNkZmQzMXk1NDE%3D.jpg

theseven
1st October 2006, 11:36 PM
and this one!!

http://www.we-todd-did-racing.com/wetoddimage.wtdr/wNDI4NTI0NnM0MTNkZmQzMXk1NDE%3D.jpg


@hooman
read this one man... this clearly said that koni supplied the washers!! u haven't given me any...

http://www.honda-tech.com/zerothread/1106020

Hooman
2nd October 2006, 11:47 PM
i honesty can't remember those being supplied or not.....plus ur write up is for an integra not a prelude they r different cars.

theseven
3rd October 2006, 12:00 AM
i called up suspension place in melbourne today... checked with them... they said it was suppose to be supplied...